Firewall на OpenWRT под L2TP

Здесь обсуждаются различные программы, компьютеры, ноутбуки, операционные системы, связь, компьютерные сети, модемы, смартфоны, сотовые телефоны, цифровое и IP-телевидение и т.д.

Модераторы: Aneta, ru

Аватара пользователя
Lucifer87
Почетный участник форума
Сообщения: 1177
Зарегистрирован: 11 мар 2010 20:16
Откуда: Санкт-Петербург
Контактная информация:

Firewall на OpenWRT под L2TP

Сообщение Lucifer87 » 05 апр 2015 14:00

Приветствую! Есть тут люди которые знают как настроить фаерволл под данное соединение? Который день уже не могу победить... :(
Необходимые пакеты все установлены, соединение настроил (индикатор показывает инет), но по факту его нет.
да, я - хам... но присмотрись и ты увидишь в моих постах быть может... правду?..
I do not believe anyone...

Аватара пользователя
feRL
Сообщения: 218
Зарегистрирован: 04 ноя 2006 18:17

Re: Firewall на OpenWRT под LTP2

Сообщение feRL » 05 апр 2015 21:15

Lucifer87 писал(а):Приветствую! Есть тут люди которые знают как настроить фаерволл под данное соединение? Который день уже не могу победить... :(
Необходимые пакеты все установлены, соединение настроил (индикатор показывает инет), но по факту его нет.
команду MASQUERADE использовал для соединение?

Аватара пользователя
Lucifer87
Почетный участник форума
Сообщения: 1177
Зарегистрирован: 11 мар 2010 20:16
Откуда: Санкт-Петербург
Контактная информация:

Re: Firewall на OpenWRT под LTP2

Сообщение Lucifer87 » 05 апр 2015 22:50

Я не настолько разбираюсь в линуксовых системах... =(
да, я - хам... но присмотрись и ты увидишь в моих постах быть может... правду?..
I do not believe anyone...

Аватара пользователя
Lucifer87
Почетный участник форума
Сообщения: 1177
Зарегистрирован: 11 мар 2010 20:16
Откуда: Санкт-Петербург
Контактная информация:

Re: Firewall на OpenWRT под LTP2

Сообщение Lucifer87 » 05 апр 2015 22:53

Забыл указать что перепрошивал роутер TPLink-WR741ND
да, я - хам... но присмотрись и ты увидишь в моих постах быть может... правду?..
I do not believe anyone...

Аватара пользователя
ru
забанен
Сообщения: 5795
Зарегистрирован: 23 июн 2006 08:42

Re: Firewall на OpenWRT под LTP2

Сообщение ru » 06 апр 2015 07:51

Lucifer87 писал(а):Я не настолько разбираюсь в линуксовых системах... =(
а может еще и firewall от NAT не отличаете? :lol:
результат вывода команды iptables -t nat -L -n для начала покажите

Аватара пользователя
ru
забанен
Сообщения: 5795
Зарегистрирован: 23 июн 2006 08:42

Re: Firewall на OpenWRT под LTP2

Сообщение ru » 06 апр 2015 19:40

и ifconfig еще!

Аватара пользователя
Lucifer87
Почетный участник форума
Сообщения: 1177
Зарегистрирован: 11 мар 2010 20:16
Откуда: Санкт-Петербург
Контактная информация:

Re: Firewall на OpenWRT под LTP2

Сообщение Lucifer87 » 06 апр 2015 22:31

ru писал(а):
Lucifer87 писал(а):Я не настолько разбираюсь в линуксовых системах... =(
а может еще и firewall от NAT не отличаете? :lol:
честно признаюсь - не всегда! :lol:
ru писал(а): результат вывода команды iptables -t nat -L -n для начала покажите

Код: Выделить всё

[spoiler=команда] root@OpenWrt:~# iptables -t nat -L -n
Chain PREROUTING (policy ACCEPT)
target     prot opt source               destination

Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

Chain POSTROUTING (policy ACCEPT)
target     prot opt source               destination[/spoiler]
ru писал(а): и ifconfig еще!

Код: Выделить всё

[spoiler=нетворк] config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '***********'

config interface 'lan'
	option ifname 'eth0'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.2'

config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'
        option metric '50' 
        option reqopts 'routes msstaticroutes'

config interface 'vpn'
        option proto 'l2tp'
        option server 'tp.internet.beeline.ru'
        option username '089***'
        option password '089***'
        option keepalive '20 5'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 4' [/spoiler]
ипконфига не нашел, думаю подойдет нетворк?
Последний раз редактировалось Lucifer87 06 апр 2015 22:39, всего редактировалось 1 раз.
да, я - хам... но присмотрись и ты увидишь в моих постах быть может... правду?..
I do not believe anyone...

Аватара пользователя
ru
забанен
Сообщения: 5795
Зарегистрирован: 23 июн 2006 08:42

Re: Firewall на OpenWRT под LTP2

Сообщение ru » 06 апр 2015 22:38

попробуйте iptables -t nat -I POSTROUTING -s 192.168.1.0/24 -j MASQUERADE
Про DNS на клиентских компьютерах еще не забудьте(лучше на время проверки 8.8.8.8 указать)
Если интернет не заработает, то покажите какое значение у параметра net.ipv4.forward в файле /etc/sysctl.conf

Аватара пользователя
Lucifer87
Почетный участник форума
Сообщения: 1177
Зарегистрирован: 11 мар 2010 20:16
Откуда: Санкт-Петербург
Контактная информация:

Re: Firewall на OpenWRT под LTP2

Сообщение Lucifer87 » 06 апр 2015 22:41

что-то спойлер не получилось сделать, давно на форумах не сидел...
да, я - хам... но присмотрись и ты увидишь в моих постах быть может... правду?..
I do not believe anyone...

Аватара пользователя
Lucifer87
Почетный участник форума
Сообщения: 1177
Зарегистрирован: 11 мар 2010 20:16
Откуда: Санкт-Петербург
Контактная информация:

Re: Firewall на OpenWRT под LTP2

Сообщение Lucifer87 » 06 апр 2015 22:41

ru писал(а):попробуйте iptables -t nat -I POSTROUTING -s 192.168.1.0/24 -j MASQUERADE
Про DNS на клиентских компьютерах еще не забудьте(лучше на время проверки 8.8.8.8 указать)
Если интернет не заработает, то покажите какое значение у параметра net.ipv4.forward в файле /etc/sysctl.conf
сейчас сделаю.
да, я - хам... но присмотрись и ты увидишь в моих постах быть может... правду?..
I do not believe anyone...

Аватара пользователя
Lucifer87
Почетный участник форума
Сообщения: 1177
Зарегистрирован: 11 мар 2010 20:16
Откуда: Санкт-Петербург
Контактная информация:

Re: Firewall на OpenWRT под LTP2

Сообщение Lucifer87 » 06 апр 2015 22:53

не алло
net.ipv4.ip_forward=1
да, я - хам... но присмотрись и ты увидишь в моих постах быть может... правду?..
I do not believe anyone...

Аватара пользователя
ru
забанен
Сообщения: 5795
Зарегистрирован: 23 июн 2006 08:42

Re: Firewall на OpenWRT под LTP2

Сообщение ru » 06 апр 2015 23:08

Lucifer87 писал(а):не алло
net.ipv4.ip_forward=1
должно работать
я тыщу раз так делал!

сделай
ping ya.ru
ping 8.8.8.8
tracert 8.8.8.8
все команды с клиента роутера

Аватара пользователя
Lucifer87
Почетный участник форума
Сообщения: 1177
Зарегистрирован: 11 мар 2010 20:16
Откуда: Санкт-Петербург
Контактная информация:

Re: Firewall на OpenWRT под LTP2

Сообщение Lucifer87 » 06 апр 2015 23:17

хорошо, попробую.
почитал, нахапался верхушек точнее, что надо в фаерволе правила настроить что и как, нет? я там так намудрил...
да, я - хам... но присмотрись и ты увидишь в моих постах быть может... правду?..
I do not believe anyone...

Аватара пользователя
ru
забанен
Сообщения: 5795
Зарегистрирован: 23 июн 2006 08:42

Re: Firewall на OpenWRT под LTP2

Сообщение ru » 07 апр 2015 10:00

Lucifer87 писал(а):хорошо, попробую.
почитал, нахапался верхушек точнее, что надо в фаерволе правила настроить что и как, нет? я там так намудрил...
судя по iptables -t nat -L -n специально настраивать ничего не надо. Транзитный траффик разрешен.
Покажи еще iptables -L -n на всякий случай. Вдруг там FORWARD в DROP выставлен.

Аватара пользователя
ru
забанен
Сообщения: 5795
Зарегистрирован: 23 июн 2006 08:42

Re: Firewall на OpenWRT под LTP2

Сообщение ru » 07 апр 2015 16:43

Lucifer87 писал(а):ипконфига не нашел, думаю подойдет нетворк?
внимательней будь :D
не ipconfig, a ifconfig :wink:

Ответить